Plugin kodi

Reporte aqui tudo o que não está a funcionar bem

Moderador: jamlvs

brtiberio
Newbie
Mensagens: 3
Registado: 16 ago 2005, 00:00

Re: Plugin kodi

Mensagem por brtiberio » 09 fev 2017, 09:43

No meu caso continuo com o 16.1
mustangbolt
Newbie
Mensagens: 2
Registado: 28 jan 2012, 00:00
Localização: Porto

Re: Plugin kodi

Mensagem por mustangbolt » 10 fev 2017, 12:01

Tenho o Kodi 17 instalado de raiz, não fiz update do 16.1 para o 17, e não consigo usar o plugin. Diz sempre que não encontra legendas, quer seja pesquisa automática ou manual.
Mavors
Newbie
Mensagens: 3
Registado: 10 nov 2004, 00:00

Re: Plugin kodi

Mensagem por Mavors » 14 fev 2017, 17:14

Eu diagnostiquei o problema na transição do 16.1 para o 17, mas pode ter sido apenas coincidência.

O que é certo é que continua a não ser possível utilizar o plugin.
No meu não diz "Legendas não encontradas" mas sim que não não consegue conectar ao site.
Avatar do Utilizador
jamlvs
Admin
Admin
Mensagens: 1407
Registado: 14 nov 2004, 00:00
Localização: Vila Nova de Gaia

Re: Plugin kodi

Mensagem por jamlvs » 16 fev 2017, 19:34

Quick update:

Foi enviada a correção para o dev vai para 1 mês mas ele ainda não a aceitou, por isso o mais certo é fazermos nós um plugin oficial.

Imagem
cEpTrOn
Newbie
Mensagens: 3
Registado: 27 mai 2006, 00:00

Re: Plugin kodi

Mensagem por cEpTrOn » 22 mar 2017, 16:57

Boas pessoal,

Para quem tentou remover o ficheiro:
"The.Grand.Tour.2016.S01E02.Operation.Desert.Stumble.1080p.AMZN.WEBRIP.AAC.5.1.HEVC.x265.sharpysword."

na pasta:
C:\Users\"o vosso username"\AppData\Roaming\Kodi\userdata\addon_data\service.subtitles.legendasdivx\temp\8ec763\

e nao consegue...

não é preciso nenhum programa especial, basta abrir o command line e escrever: del *.*

voilá, ficheiro já era, kodi 17 com legendasdivx a funcionar.

observação: caso o plugin dê erro, insiste, a primeira tentativa de pesquisa normalmente dá sempre erro, aperta novamente :P

espero ter ajudado, abraços.
lt707
Newbie
Mensagens: 1
Registado: 13 out 2005, 00:00

Re: Plugin kodi

Mensagem por lt707 » 23 mar 2017, 12:25

Boas
Eu com o kodi 17.1 continuo sem poder aceder, ou pelo menos diz-me que não tem legendas para nada.

Não existe um upgrade ao plugin?

Cumprimentos
warl0rd
Newbie
Mensagens: 39
Registado: 20 nov 2004, 00:00

Re: Plugin kodi

Mensagem por warl0rd » 21 abr 2017, 00:09

Existem algumas legendas que nunca consigo fazer download com o plugin, por exemplo as submetidas pelo Virtual_PT para a série Designated Survivor. No entanto se fizer download das legendas submetidas por outra pessoa, consigo sem problemas.

Alguma dica?

22:05:36 T:1593832464 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.KeyError'>
Error Contents: ('filename',)
Traceback (most recent call last):
File "/home/xbmc/.kodi/addons/service.subtitles.legendasdivx/service.py", line 565, in <module>
subs = Download(params["id"], params["filename"])
KeyError: ('filename',)
-->End of Python script error report<--
22:05:36 T:1663038480 ERROR: GetDirectory - Error getting plugin://service.subtitles.legendasdivx/?action=download&id=252739&filename=From: Virtual_PT - Designated Survivor (2016) hits: 68 - Designated Survivor ^M S01E12 - "The End of the Beginning" ^M ^M Release/b> ^M ^M Designated.Survivor.S01E12.1080p.WEBRip.X264-DEFLATE ^M ^M ====
brtiberio
Newbie
Mensagens: 3
Registado: 16 ago 2005, 00:00

Re: Plugin kodi

Mensagem por brtiberio » 28 abr 2017, 15:05

Pode não ser a solução para todos os caso aqui presentes mas no meu caso, resolvi a situação da seguinte forma:
Ao correr o Kodi em linha de comandos deparei-me com a seguinte mensagem ao tentar pesquisar legendas:

Código: Selecionar todos

extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
Sendo que estou a usar Raspbian jessie, bastou-me realizar o seguinte update:

Código: Selecionar todos

sudo -H pip install --upgrade pyopenssl
Aproveitei a boleia e fiz o update a todos os pacotes do python que estavam desatualizados e tambem os pacotes dos sistema:

Código: Selecionar todos

sudo apt-get update
sudo apt-get upgrade -y
pip list --outdated --format=freeze | grep -v '^\-e' | cut -d = -f 1  | xargs -n1 sudo -H pip install -U
Reinicei e já consegui usar o plugin para pesquisar e a mensagem deixou de aparecer.
kriaxpatala
Newbie
Mensagens: 1
Registado: 12 nov 2004, 00:00

Re: Plugin kodi

Mensagem por kriaxpatala » 04 mai 2017, 11:42

Olá. Seguindo a dica do brtiberio corri o Kodi em linha de comando e também obtive o mesmo erro de python (aqui estou a usar Linux Mint 18 que é baseado no Ubuntu 16.04). Para o resolver consultei os foruns e aparentemente basta atualizar (ou instalar) estes 2 pacotes para versões mais recentes que as que estão nos repositórios stable:

http://security.ubuntu.com/ubuntu/pool/ ... _amd64.deb
http://es.archive.ubuntu.com/ubuntu/poo ... -1_all.deb

Façam o download para a /home/user e instalem com o comando:

sudo apt install ~/python-cryptography_1.7.1-2_amd64.deb ~/python-openssl_16.2.0-1_all.deb

Isto resolveu o erro e o problema na pesquisa de legendas no Kodi 16 Jarvis (testei o 17 e crashava por todos os lados).

Isto aparentemente ocorre por causa de problemas de configuração no Kodi, e parece que não acontece quando se acaba de instalar o mesmo (ou seja, o plugin legendasdivx.com funciona numa instalação limpa). No meu caso acho que foi uma skin assim mais alternativa que meti que deu cabo e depois já nem revertendo me safei.

Opcional

Antes disto já tinha tido problemas a usar o plugin e liguei o debug nos logs do kodi onde apanhei alguns avisos que levaram a que alterasse o plugin (ficheiro service.py).

a) Substitui as entradas 'legendasdivx.com' por 'legendasdivx.pt' porque me pareceu ser o mais correto neste momento;

b) Na linha 322 retirei as aspas da searchstring. Ficou simplesmente:

searchstring = title + ' ' + year

Porque fazendo a pesquisa diretamente no site usando as aspas devolve-me erro, e sem nada funciona.

Cmps.
Ricardo_Rocha
Newbie
Mensagens: 1
Registado: 26 ago 2006, 00:00

Re: Plugin kodi

Mensagem por Ricardo_Rocha » 21 jun 2017, 09:14

Alguma novidade em relação ao plugin?
Responder